Tech Tips for Techs: Windows 10 and the Cisco AnyConnect VPN client

Standard

 

As a tech who provides remote support, I rely fairly heavily on several VPN clients to connect to a variety of networks for my day-to-day work. I recently acquired the Technical Preview for Windows 10, and immediately installed it on one of my spare laptops.

(Disclaimer – I subscribe to the “every-other-one” theory in regards to Microsoft OSes. This is to say that every other operating system that M$ releases is a complete piece of garbage. e.g.,

Windows 3.1 – crap
Windows 3.11 – not bad
Windows 95 – crap
Windows 98 – not bad
Windows ME – crap
Windows 2000 – not bad
[exception] Windows XP – not bad
Windows Vista – crap
Windows 7 – not bad
Windows 8 – crap

I completely skipped Windows 8 because I despise the interface, so I avoid it like the plague.)

W10

Microsoft’s Windows 10 Start Menu

That said, I’m surprisingly not-as-disgusted by the Windows 10 interface as I thought I might have been, despite how many remnants of 8 are hanging around. I have to hand it to Microsoft — they did a pretty good job melding the two without completely offending the zealots of both the 7 and 8 camps. After deciding not to promptly format the hard drive after the install, I started installing most of my ‘regular’ applications onto it without any drama until I got to the Cisco AnyConnect VPN client.

I should have known.

After typing in my firewall’s address and pressing Enter, I was promptly greeted with a message saying "Failed to initialize connection subsystem." Gee – that’s nice. A cursory search of the intArwebz brought me to a couple of common things and solutions people have seen with this piece of software: changing the name of the connection in the registry, uninstall and reinstall, deleting multiple instances of the VPN adapter, etc etc. Of all the things I tried, I didn’t think to try the most obvious (which was the winner, I might add.) So much for the K.I.S.S. principle.

First, I changed the DisplayName of the vpnva service in HKLM\SYSTEM\CurrentControlSet\Services\vpnva by deleting the string of garbage in front of the word Cisco (@oem8.inf,%VPNVA64_Desc%). This caused the connection process to “think” a little longer than normal, but ultimately brought up the same error. Drat.

Second, I noticed that the VPN Adapter in my network connections was disabled. Re-enabled it… same problem. Ugh.

Third, I tried uninstalling, cleaning out the registry, rebooting, checking the registry again, rebooting again, and reinstalling. Same problem.

Fourth, I was going to manually tell it to Run as Administrator, but before clicking the option I was reminded about Compatibility Mode. D’oh! How could I have forgotten that? I set it to run in compatibility mode for Windows 7, fired it up, and it connected. Like a charm. No fuss, no muss. Evidently, there’s something about the Windows 10 kernel that causes the 3.1.x AnyConnect software not to want to connect. So for anyone out there running on the bleeding edge, and you use Cisco’s AnyConnect client… check the simple things first. ;)

 

Related posts: